All Collections
Getting Started with Tiller
Microsoft Excel
Using the Tiller Money Feeds add-in for Microsoft Excel
Using the Tiller Money Feeds add-in for Microsoft Excel

Learn all about Tiller's add-in for Microsoft Excel

Heather Phillips avatar
Written by Heather Phillips
Updated over a week ago

The Tiller Money Feeds add-in for Microsoft Excel allows you to automate your bank transactions and balances to an Excel workbook.

How to Install the Tiller Money Feeds add-in

The Tiller Money Feeds add-in is only compatible with Excel for Desktop when installed from a Microsoft 365 subscription or Excel Online.

  1. Open Add-ins from the Home ribbon in an Excel workbook

  2. Search for "Tiller" in the Store

  3. Click "Add" and the add-in will appear in your Data ribbon.

Signing in to the Tiller Money Feeds add-in

When getting started with Tiller for Excel, after you've installed the add-in, you'll need to sign in to the Tiller service via the add-in using the account that's associated with your Tiller subscription. This might not be the account you use for Microsoft 365 and that’s okay.

You may also need to sign in again if your already linked workbook has been closed for a while.

How to sign in to the Excel add-in

  1. Open the Data ribbon in Excel

  2. Click the blue "Open Tiller" button

  3. Click "Sign in to Tiller"

  4. Authenticate with the account you use for Tiller.

Setting up the data feed connection

In order to establish a data feed to an Excel workbook you must first link it to the Tiller Console via the Tiller add-in for Excel. This link establishes a connection between the Excel workbook and Tiller’s databases.

You should save the Excel workbook before you can link it to the Tiller Console.

The workbook will appear on your Tiller Console, denoted with an “Excel” flag. It also counts toward your five sheet limit.

How to link an Excel workbook to Tiller:

  1. Make sure the workbook has been saved with a unique name. Choose a storage location you’ll remember. If you’re storing your Excel workbook on OneDrive, be sure to pay attention to the account associated with the OneDrive as this could be different than the account used for Tiller.

  2. Open and sign in to the Tiller add-in in Excel.

  3. Click the “Link workbook” button.

  4. Confirm that you would like to link the workbook.

Linking accounts to your Excel workbook

You can link accounts to your Excel workbooks directly in the workbook via the Tiller add-in or via the Tiller Console so that Tiller will pull the data into the Excel workbook when you click “Update” in the add-in.

  1. Open and sign in to the Tiller add-in in Excel.

  2. Click the “Link accounts” button in the add-in task pane.

  3. Toggle on any account you want linked to this workbook for automated data feeds. If you don’t see all your accounts listed, try scrolling down in the task pane.

  4. Click “Confirm” to link the accounts.

  5. Click the “Fill” button to pull in data from the newly linked account.

To add more accounts for linking visit the Tiller Console and click “Add accounts” under the Account Summary to connect more institutions to Tiller.

Keeping your bank data fresh

Click the “Fill” button in the Tiller Money Feeds add-in for Excel to pull in the latest bank transactions and balances into your workbook. When new data is available to add to your sheet the Fill button will be blue.

  1. Open the Excel add-in from the Data ribbon at the top of your workbook.

  2. Click the “Fill” button at the top. A blue "Fill" button indicates that new bank data is available to add to your workbook.

  3. Save your workbook. Filled transactions and balances may not be re-filled if you forget to save.

For accounts that can automatically refresh, Tiller pulls data from your bank about once a day, which makes it available in our databases. Once it’s available, clicking the "Fill" button will pull it into your Excel workbook.

If the Fill button is not blue indicating new data is available from your banks try visiting the Tiller Console at https://my.tillerhq.com/ to refresh accounts under the Account Summary.

Some accounts cannot automatically refresh and will require you to visit the Console at https://my.tillerhq.com/ to refresh them.

Using AutoCat to categorize transactions

AutoCat allows you to build a custom rule set to help you automatically categorize transactions.

  1. Install the AutoCat rule sheet by clicking the "Install AutoCat" button in the add-in

  2. Build rules on the AutoCat sheet (tab along the bottom)

  3. Click "Run AutoCat" in the add-in to have it categorize transactions based on your rules.

Tools

You can manually track balances for accounts that Tiller can't automate and add manual transactions using the Tiller Money Feeds add-in for Excel.

The Tiller Money Feeds add-in for Excel only doesn't have a way to automatically match and merge manual (reconcile) transactions that you've added when Tiller brings them in so you would end up with duplicates in that situation. You'd need to manually delete one of the instances if you're using Excel.

Manage Templates

The Manage Templates feature in the Tiller Money Feeds add-in allows you to install, restore, or update Foundation Template dashboards and sheets in Excel.

Note: Templates that include charts can't be installed/restored in Excel Online. The Monthly Budget sheet can be installed/restored but will not include the spark line visual available in the desktop version of Excel.

The following sheets are available to insert, update, or restore:

  • Spending Trends

  • Monthly Budget

  • Yearly Budget

  • Balances

  • Accounts

  • Insights

If you don’t already have one of the above sheets installed you'll see it under "New Templates to Add." If you already have one of them installed you'll see the "update" button if a newer version is available or a "restore" button if you have the current version already installed.

Installing templates

If you opt to install one of the Foundation template sheets and a dependent sheet is missing the add-in will also install the dependent sheet.

For example, if you install the Balances sheet and the Accounts sheet is missing the add-in will also install the Accounts sheet because the Balances sheet is dependent on it.

Upgrading sheets

You'll see an "update" button if a newer version of the template is available.

  1. Launch the Tiller Money Feeds add-in from the data ribbon

  2. Choose Tools > Manage Templates

  3. Click “Update” where applicable

  4. Choose whether you want to Archive or Overwrite

    1. Archiving is recommended for upgrading the Accounts sheet if you’ve applied class overrides or Groups.

    2. Overwrite existing is fine for all other sheets if you have not made customizations to formulas or hidden areas of the dashboard.

  5. When the process is finished a success message will appear. Do not make edits to your sheet while the upgrade process is running.

Restoring sheets

You can restore a broken Foundation Template dashboard or visualization using the Manage Templates feature.

  1. Launch the Tiller Money Feeds add-in from the data ribbon

  2. Choose Tools > Manage Templates

  3. Click “Restore” for the sheet that needs to be fixed

  4. Choose whether you want to Archive or Overwrite

    1. Archiving is recommended for upgrading the Accounts sheet if you’ve applied class overrides or Groups.

    2. Overwrite existing is fine for all other sheets if you have not made customizations to formulas or hidden areas of the dashboard.

  5. When the process is finished a success message will appear. Do not make edits to your sheet while the upgrade process is running.

Disconnecting a Workbook

If you would like to disconnect the data feed for an Excel workbook you can unlink it. You can unlink it from directly within the Excel workbook via the Tiller Money Feeds add-in.

Unlinking a workbook will remove it from your Tiller Console, free up one of your five sheet slots, and you will no longer be able to fill it with data from Tiller.

How to unlink a workbook

  1. Open and sign in to the Tiller add-in in Excel.

  2. Click on the Settings tab

  3. Click the “Unlink workbook” button.

  4. Confirm that you want to unlink the workbook.

Note: If you relink a workbook that has previously been linked to your Tiller Console you will likely end up with duplicate transactions in the workbook.

Stopping the data feed for an account

If you no longer wish to pull data from an account into your Excel workbook you can unlink it from the Tiller Console or directly from the add-in.

ℹ️ Unlinking a workbook does not remove the data Tiller has already pulled into the workbook.

If you no longer wish to see data for an unlinked account in your workbook you will need to manually remove it from the Transactions sheet and the Balance History sheet.

  1. Open and sign in to the Tiller add-in in Excel.

  2. Click the vertical “...” in the top right of the Linked Accounts area at the top of the add-in.

  3. Toggle off any account you no longer want linked to this workbook for automated data feeds.

  4. Click “Confirm” to unlink the accounts.

  5. (Optional) manually remove data for the account from the Transactions and Balance History sheets. Review the guide here.

How to Uninstall the Excel Add-In

If you need to uninstall the Excel add-in you can use the following steps.

  1. Open Microsoft Excel.

  2. Click the Insert tab.

  3. Click the "My add-ins" button.

  4. Click the ... next to the Tiller add-in

  5. Choose Remove.

  6. Read the notice that appears regarding other devices and click Remove.

Did this answer your question?