Do I need to use this guide?

This guide is for customers who have been on the new ("ysl") version of our data feeds since they started with Tiller, but are still using a Feed Bot sheet and need to transition to using a Tiller Money Feeds sheet. If you DID NOT receive an email indicating that your bank feeds have been upgraded then this is the guide you want to use. You can search your inbox for an email with subject: "Action required: your Tiller bank feeds have been upgraded"

If you are still on the old version ("legacy") of our data feeds or were just recently upgraded to the new version ("ysl") (you received an email with subject: "Action required: your Tiller bank feeds have been upgraded") and also need to transition off a Feed Bot sheet you need to use this guide instead.

Do I need to completely start over in a new spreadsheet?

You do have to create a new spreadsheet, but there are a few options to consider depending on how important your categorized data or customized template is to you. You can start fresh in a new sheet, migrate just your categorized transactions, categories, and manual accounts into the Foundation Template, or make a copy of your existing template and manually modify it to work with Tiller Money Feeds.

Read more on the options below.

Option 1: A fresh start

Easiest option & you're okay with just seeing the new uncategorized upgraded accounts' data in your new spreadsheet and you don't care to see your historical categorized transaction data in the sheet.

Time to transition: 10 minutes

Option 2: Leave behind the old template, but bring over the categorized data

You want to see your historical categorized transactions, AutoCat rules, manually tracked accounts in your new spreadsheet, but you're okay starting in a new, better template.

Time to transition: 20 minutes - 1 hour

Option 3: keep your template and modify it to work with Tiller Money Feeds

You want to continue using a template that you have invested a lot of time into customizing such as building your own custom reports, dashboards, charts, and queries. You're probably an advanced spreadsheet user and would not want to have to re-create all those customizations in a new spreadsheet.

Time to transition: 45 minutes - 2+ hours

Option 1: A fresh start

The easiest option for transitioning off the Feed Bot and into a Tiller Money Feeds Google Sheet is to just start fresh in a new spreadsheet using the Foundation template. The steps for this workflow are documented here.

This means you would not see any of your categorized historical data from the past several years in this new spreadsheet and you may want to clear out transactions from prior years or months so there is less to re-categorize. Think of this as a fresh start with Tiller.

  1. Log in to the Tiller Console (https://sheets.tillerhq.com/auth/google)

  2. Click "Create a spreadsheet" and choose your platform (Google Sheets or Excel)

    1. Follow the instructions on the Install Help / Getting Started tab of the spreadsheet.

  3. Link your financial accounts to the sheet when you reach the account linking step.

  4. Set up your template

    1. Google Sheets Foundation Template Quick Start Guide

    2. Microsoft Excel Tiller Foundation Template Guide

  5. Unlink your Feed Bot spreadsheet from the Console

    1. On the Console click "Open sheet" and from the file menu choose "Make a copy"

    2. Back on the Console, click the sheet's name and then choose "Unlink this sheet"

  6. Get to know the Tiller Money Feeds add-on to understand what's different about your new spreadsheet and how to keep it filled with new data.

  7. Join the Tiller Community and explore Tiller Community Solutions for Google Sheets

Option 2: Leave behind the old template, but bring over the categorized data

If you have a lot of historical categorized transaction data that you really want to bring over we recommend the below workflow that involves creating a new Google Sheet starting with the Foundation Template (our only supported template now) and migrating your categorized data, categories, manually tracked accounts, and AutoCat rules using the Tiller Migration Helper add-on.

Step 1: Create a new Google Sheet
Step 2: Migrate data from your Feed Bot sheet

Step 3: Unlink your Feed Bot sheet

Step 4: Review the Resources section for next steps

Step 1: Create a new Google Sheet

  1. Install the Tiller Money Feeds add-on.

  2. Open the Foundation Template (or a blank Google Sheet if you prefer to build your own).

    1. You can also start in a blank Google Sheet if you prefer not to use the Foundation Template, but you will need to launch the Tiller Money Feeds add-on from the Extensions menu to link the sheet and fill it with Transaction data.

  3. Click "Use" in the sidebar that appears after starting with the Foundation template or Launch the Tiller Money Feeds add-on from the Extensions menu at the top of your Google Sheet.

  4. Sign in to Tiller using the Google account you used to subscribe to Tiller.

  5. Link the sheet to the Console.

  6. Link the same accounts to the sheet.

    1. ⚠️ If you will be linking more than 10 accounts we recommend linking in batches of 2 or 3 accounts at a time to ensure that the fill process does not time out due to a large data set.

  7. If you're linking accounts in batches, wait for a successful fill and then click "Connected Accounts" to link a few more accounts.

⚠️ If the fill process takes more than about 5 minutes and you do not see a success message indicating "x transactions/balances added"

  1. Open the File menu in the Google Sheet

  2. Choose Version History

  3. Restore your sheet to the first version

  4. Start over and try linking fewer accounts at one time.

Step 2: Migrate data from your Feed Bot sheet

Follow the steps in this guide to migrate data from your previous sheet

Step 3: Unlink your Feed Bot sheet

  1. On the Console click "Open sheet" and from the file menu choose "Make a copy"

  2. Back on the Console, click the sheet's name and then choose "Unlink this sheet"

Step 4: Review the Resources section for next steps

  1. Get to know the Tiller Money Feeds add-on to understand what's different about your new spreadsheet and how to keep it filled with new data.

  2. Join the Tiller Community and explore Tiller Community Solutions for Google Sheets

  3. Review other resources

Option 3: keep your template and modify it to work with Tiller Money Feeds

Generally this is going to be the approach you'll want if you're an advanced spreadsheet user and started with a "raw data template" or the "build your own template." Most likely you will choose this option if you're using a template that you've put a lot of customization into outside of just categorizing transactions, building AutoCat rules, and manually tracking accounts (e.g. you have built your own custom dashboards, charts, reports, or other visualizations). You can continue using that template following the steps below.

⚠️ We no longer offer support for non-Foundation Template Google Sheets. If you're using one our old templates and didn't build your own reports we recommend that you just start fresh or create a new Foundation Template sheet and migrate data.

Step 1: Get your Feed Bot sheet up to date

Step 2: Make a copy of your Feed Bot sheet

Step 3: Update your Balance History sheet to use Account ID

Step 4: Clean up duplicate balance history entries

Step 5: Link the sheet using Tiller Money Feeds

Step 6: Clean up duplicate transactions

Step 7: Upgrade your Accounts sheet

Step 8: (optional) Set up manual accounts in Tiller Money Feeds

Step 9: Transitioning AutoCat (only necessary if you were using AutoCat)

Step 10: Rework other customizations (if needed)

Step 11: Unlink your Feed Bot sheet

Step 1: Get your Feed Bot sheet up to date

  1. Visit the Console and make sure that all your accounts are refreshed and the latest available data is in your spreadsheet. Check the Account Summary for last refresh times.

  2. Categorize all your newest transactions. This will help you clean up duplicates.

Step 2: Make a copy of your Feed Bot sheet

  1. Open the File menu

  2. Choose "Make a copy"

  3. Update the name so you'll know which sheet is your new one to use going forward

Step 3: Update your Balance History sheet to use Account ID

Newer sheets no longer fill the Index number column in Balance History (usually hidden) to uniquely identify accounts. See notes about Index vs Account ID below.

  1. Open the Balance History sheet (if you don't see it, open the View menu > Hidden Sheets to unhide it)

  2. Insert a column to the right of the last visible column (right click and choose Insert 1 right)

  3. Enter Account ID for the header (row 1) for the new column

Step 4: Clear your balance history entries (optional)

  1. Open the Balance History sheet

  2. Sort the Balance History sheet by the Index column

  3. Clear all rows except row 1 where the Index number is NOT 9999

In the next step the add-on will repopulate all of your Balance History entries for automated accounts. To reduce the amount of data in the Balance History sheet we recommend this step so that the add-on does not get crash while trying to sort a very large data set. Accounts with Index 9999 are manually tracked accounts.

⚠️ If you have manually added balances for automated accounts (e.g. perhaps on days when Tiller missed a balance) you may not want to perform this step since the next step would not bring those balances back into your sheet.

Step 5: Link the sheet using Tiller Money Feeds

  1. Install the Tiller Money Feeds add-on

  2. Open the Extensions menu in the new (copy) sheet

  3. Choose Tiller Money Feeds > sign in to Tiller

  4. Click the Sign in with Google button and use your Tiller subscribed Google Account to sign in

  5. Link the sheet and choose the same accounts that you already had linked to the original one and confirm

    1. ⚠️ If you will be linking more than 10 accounts we recommend linking in batches of 2 or 3 accounts at a time to ensure that the fill process does not time out due to a large data set.

  6. If you're linking accounts in batches, wait for a successful fill and then click "Connected Accounts" to link a few more accounts.

  7. Tiller Money Feeds will feed your sheet with transactions and balance history. This will result in a lot of duplicates.

Step 6: Clean up duplicate transactions

If you made sure your sheet was fully up to date before making a copy of it and you categorized all transactions before setting up the data feed with the Tiller Money Feeds add-on you can easily clean out duplicates using a filter.

  1. Turn on the filter in your Transactions sheet

  2. Filter the Category column to show only blank rows

  3. Clear out all Transactions where the Category is blank (these are the duplicates)

Step 7: Upgrade your Accounts sheet

  1. In your new sheet, rename the Accounts sheet (right click the tab) to Accounts-Archive.

  2. Delete the Balances sheet (right click to delete) - this version no longer works with Tiller Money Feeds.

  3. Launch the Tiller Money Feeds add-on from the Extensions menu

  4. Click "Templates" in the sidebar and "Adopt" any sheets if prompted.

  5. Install the Accounts sheet and then the Balances sheet by clicking the "Install template" button under each.

  6. Using your Accounts-archive sheet as a reference, reselect your accounts using the dropdown menu in column A on the new Accounts sheet and apply class overrides as needed and assign accounts to groups if desired.

Step 8: (optional) Set up manual accounts in Tiller Money Feeds

The new Accounts sheet doesn't give the option to save balances for manually tracked accounts like the original version did. Manual accounts are entered and updated using the Tiller Money Feeds add-on. If you were manually tracking accounts in the right side area of the Accounts sheet follow these steps:

  1. In your new sheet, open the Balance History sheet (from View menu > Hidden sheets > show Balance History if you don't see the tab)

  2. Filter the Balance History sheet to only show accounts with an index of 9999. You may need to unhide the index column.

  3. Sort the Balance History sheet by Account or Account name column.

  4. Launch the Tiller Money Feeds add-on (from the Add-ons menu at the top of your Google Sheet)

  5. Click "Manual Accounts"

  6. Enter the information for a manual account as it appears in the Balance History sheet. You only need to save one entry per manual account.

  7. Copy the Account ID generated by the Tiller Money Feeds add-on that starts with "manual:" and paste it into all entries for that manual account. ⚠️ Do not use the quick fill square for this step to avoid it enumerating the Account ID.

  8. Repeat steps 6 and 7 for each manual account tracked.

Step 9: Transitioning AutoCat (only necessary if you were using AutoCat)

We've released a new version of AutoCat that is only available in the Tiller Money Feeds add-on. You can read more about the upgrade here.

  1. Open the Tiller Money Feeds add-on (via the Add-ons or Extensions menu at the top of your Google Sheet)

  2. Click "AutoCat" in the sidebar

  3. Click "Migrate" to migrate your ruleset to use the new format.

  4. Learn more about how to use AutoCat.

Step 10: Rework other customizations (if needed)

We deprecated the Index column fill for Google Sheets when we released the Tiller Money Feeds add-on.

If your customized dashboards, reports, or visualizations were using the Index column in the Balance History to unique identify accounts you will need to modify your visualizations/dashboards to use the Account ID as a unique identifier instead. You should only do this after you have completed all other steps for this transition option.

Step 11: Unlink your Feed Bot sheet

  1. On the Console click "Open sheet" and from the file menu choose "Make a copy"

  2. Back on the Console, click the sheet's name and then choose "Unlink this sheet"

Explore the community

Now you are all set to explore community built and supported options available in the Tiller Community Solutions add-on.

Resources

How to set up the Foundation Template

For a fresh start, feel free to clear out any historical data you don't want to see in the Transactions sheet.

Review the Foundation Template for Google Sheets Quick Start Guide

How to add more reports and dashboards

Including templates previously available on the Tiller Console

The Foundation is a great starting point for budgeting and tracking, but if you want to get the Debt Planner, Net Worth Tracker, or other Weekly Expense Tracker reports in your new Google Sheet install the Tiller Community Solutions add-on to build on top of your “foundation.”

These solutions are now supported by the Tiller Community. If you have questions about anything installed via the Tiller Community Solutions add-on please post your question in the Tiller Community and a team or community member will reply soon. We do this for the one to many benefit of the Q&A.

  1. Install the Tiller Community Solutions add-on for Google Sheets

  2. Open the Tiller Community Solutions add-on from the Add-ons menu at the top of your Foundation Template

  3. Accept the privacy and experimental tool disclaimers.

  4. Browse and add solutions from the Explore section or search for a solution at the top

  5. Use the Help tab in the Tiller Community Solutions add-on sidebar to review existing topics and post a question to the Community about a solution.

Customize your accounts

  1. Unhide the Accounts sheet in your Foundation template (View menu > Hidden sheets)

  2. Select accounts from the dropdown menu and then enter a group name.

  3. Set any necessary class overrides.

What to expect with Tiller Money Feeds

The way your bank data makes it into your spreadsheet is a little different with the Tiller Money Feeds add-on. It's not automatic. Read more here.

Did this answer your question?