Do I need to use this guide?

This guide is for customers who were just upgraded to YSL and received a confirmation email with their next steps pointing them to this guide.

There are two upgrades happening in 2022.

One upgrade is moving off the Feed Bot, which is related to how the Google Sheet gets filled with data and the second upgrade is for your data feeds version, which is how we pull data from your banks (legacy vs ysl).

Depending on which option you choose below with regarding to starting in a new spreadsheet, you may be able to start part of the upgrade now, but the upgrade of your data feeds requires action from our team. You will receive a separate email notification when we have upgraded your data feeds.

Note: If you have been on the new version (ysl) since starting Tiller (you did not receive any notification about your data feeds being upgraded to ysl) but you need to transition out of a Feed Bot sheet you should use this guide.

Do I need to completely start over in a new spreadsheet?

You do have to create a new spreadsheet, but there are a few options to consider depending on how important your categorized data or customized template is to you. You can start fresh in a new sheet, migrate just your categorized transactions, categories, and manual accounts into the Foundation Template, or make a copy of your existing template and manually modify it to work with Tiller Money Feeds.

Read more on the options below.

Option 1: A fresh start

Easiest option & you're okay with just seeing the new uncategorized upgraded accounts' data in your new spreadsheet and you don't care to see your historical categorized transaction data in the sheet.

Time to transition: 15 minutes (does not include time for re-adding all accounts on the Console)

Click here to review the steps involved.

Option 2: Leave behind the old template, but bring over the categorized data

You want to see your historical categorized transactions, AutoCat rules, manually tracked accounts in your new spreadsheet, but you're okay starting in a new, better template.

Time to transition: 30 minutes - 1 hour (does not include time for re-adding all accounts on the Console)

Click here to review the steps involved

Option 3: keep your template and modify it to work with Tiller Money Feeds

You want to continue using a template that you have invested a lot of time into customizing such as building your own custom reports, dashboards, charts, and queries. You're probably an advanced spreadsheet user and would not want to have to re-create all those customizations in a new spreadsheet.

Time to transition: 1-2+ hours (does not include time for re-adding all accounts on the Console)

Click here to review the steps involved

Option 1: A fresh start

This is the easiest option for transitioning off the Feed Bot and into a Tiller Money Feeds Google Sheet when your data feeds are upgraded. Start fresh in a new spreadsheet using the Foundation Template and only link the new YSL accounts to the new spreadsheet.

This means you would not see any of your historical data from the past several years in this new spreadsheet. Think of this as a fresh start with Tiller.

How to get started:

  1. Log in to the Console at https://sheets.tillerhq.com/auth/login

  2. Click "Add account" and re-add all your institutions

  3. Review this guide to start fresh in a Foundation Template

Option 2: Leave behind the old template, but bring over the categorized data

If you have a lot of historical categorized transaction data that you really want to bring over we recommend the below workflow that involves creating a new Google Sheet starting with the Foundation Template (our only supported template now) and migrating your categorized data, categories, manually tracked accounts, and AutoCat rules using the Tiller Migration Helper add-on.

Step 1: Create a new Google Sheet
Step 2: Migrate data from your Feed Bot sheet

Step 3: Re-add your accounts

Step 4: Link new accounts to your new Google sheet

Step 5: Merge old accounts into new accounts

Step 1: Create a new Google Sheet

  1. Install the Tiller Money Feeds add-on.

  2. Open the Foundation Template (or a blank Google Sheet if you prefer to build your own).

  3. Click "Use" in the sidebar that appears after starting with the Foundation template or Launch the Tiller Money Feeds add-on from the Extensions menu at the top of your Google Sheet.

  4. Sign in to Tiller using the Google account you used to subscribe to Tiller.

  5. Link the sheet to the Console.

  6. Link your Archived accounts only to the sheet excluding any accounts that you don't plan to re-add using the new data feeds version.

    1. ⚠️ If you will be linking more than 10 accounts we recommend linking in batches of 2 or 3 accounts at a time to ensure that the fill process does not time out due to a large data set.

  7. If you're linking accounts in batches, wait for a successful fill and then click "Connected Accounts" to link a few more accounts.

⚠️ If the fill process takes more than about 5 minutes and you do not see a success message indicating "x transactions/balances added"

  1. Open the File menu in the Google Sheet

  2. Choose Version History

  3. Restore your sheet to the first version

  4. Start over and try linking fewer accounts at one time.

Step 2: Migrate data from your Feed Bot sheet

Follow the steps in this guide to migrate your Feed Bot sheet data

🛑 You must have received a separate confirmation email from our team that your data feeds have been upgraded before you can proceed beyond this step.

Step 3: Re-add your accounts

  1. Log in to the Console at https://sheets.tillerhq.com/auth/google

  2. Click "Add accounts" under the Account Summary and re-add your institution logins.

  3. Apply account nicknames to these accounts if desired under the Account Summary by clicking the pencil icon.

⚠️ If you have trouble re-adding an account, please review the troubleshooting guide here before reaching out to our support team. You can continue with the below steps for other accounts you've been able to successfully re-add.

Step 4: Link new accounts to your new Google sheet

  1. Open your new Google Sheet powered by the Tiller Money Feeds add-on

  2. Launch the Tiller Money Feeds add-on from the Extensions menu at the top of the Google Sheet - sign in to Tiller if prompted

  3. Click "Connected Accounts" in the sidebar

  4. Link your newly added accounts to the sheet. If you will be linking more than 10 accounts we recommend linking in batches of 2 or 3 accounts at a time to ensure that the fill process does not time out due to a large data set.

Step 5: Merge old accounts into new accounts

Follow these steps to Merge & Repair old accounts into new accounts and clean up transaction duplicates

Option 3: keep your template and modify it to work with Tiller Money Feeds

Generally this is going to be the approach many of our advanced spreadsheet users want if you started with a "raw data template" or the "build your own template." Most likely you will choose this option if you're using a template that you've put a lot of customization into outside of just categorizing transactions, building AutoCat rules, and manually tracking accounts (e.g. you have built your own custom dashboards, charts, reports, or other visualizations). You can continue using that template following the steps below.

⚠️ We no longer offer support for non-Foundation Template Google Sheets. If you're using one our old templates and didn't build your own reports we recommend that you just start fresh or create a new Foundation Template sheet and migrate data.

Step 1: Make a copy of your Feed Bot sheet

Step 2: Update your Balance History sheet to use Account ID

Step 3: Re-add your accounts

Step 4: Link new accounts to your new Google sheet

Step 5: Merge old accounts into new accounts

Step 6: Upgrade your Accounts sheet

Step 7: (optional) Set up manual accounts in Tiller Money Feeds

Step 8: Transitioning AutoCat (only necessary if you were using AutoCat)

Step 1: Make a copy of your Feed Bot sheet

  1. Open the File menu

  2. Choose "Make a copy"

  3. Update the name so you'll know which sheet is your new one to use going forward

Step 2: Update your Balance History sheet to use Account ID

Newer sheets no longer fill the Index number column in Balance History (usually hidden) to uniquely identify accounts. See notes about Index vs Account ID below.

  1. Open the Balance History sheet (if you don't see it, open the View menu > Hidden Sheets to unhide it)

  2. Insert a column to the right of the last visible column (right click and choose Insert 1 right)

  3. Enter Account ID for the header (row 1) for the new column

🛑 You must have received a separate confirmation email from our team that your data feeds have been upgraded before you can proceed beyond this step.

Step 3: Re-add your accounts

  1. Log in to the Console at https://sheets.tillerhq.com/auth/login

  2. Click "Add accounts" under the Account Summary and re-add your institution logins.

  3. Apply account nicknames to these accounts if desired under the Account Summary by clicking the pencil icon.

⚠️ If you have trouble re-adding an account, please review the troubleshooting guide here before reaching out to our support team. You can continue with the below steps for other accounts you've been able to successfully re-add.

Step 4: Link new accounts to your new Google sheet

  1. Open your new Google Sheet powered by the Tiller Money Feeds add-on

  2. Install or launch the Tiller Money Feeds add-on from the Extensions menu at the top of the Google Sheet and sign in if necessary

    1. If installing the add-on for the first time you may need to refresh the browser window before the add-on will appear in the Extensions menu.

  3. Click "Connected Accounts"

  4. Link your newly added (ysl) accounts to the sheet. If you will be linking more than 10 accounts we recommend linking in batches of 2 or 3 accounts at a time to ensure that the fill process does not time out due to a large data set.

    1. ⚠️ only link the accounts that appear at the top of the Connected Accounts list. DO NOT link any accounts from the "Archived" section under Connected Accounts.

Step 5: Merge old accounts into new accounts

Follow these steps to Merge & Repair old accounts into new accounts and clean up transaction duplicates

Step 6: Upgrade your Accounts sheet

  1. In your new sheet, rename the Accounts sheet (right click the tab) to Accounts-Archive.

  2. Delete the Balances sheet (right click to delete) - this version no longer works with Tiller Money Feeds.

  3. Launch the Tiller Money Feeds add-on from the Extensions menu

  4. Click "Templates" in the sidebar and "Adopt" any sheets if prompted.

  5. Install the Accounts sheet and then the Balances sheet by clicking the "Install template" button under each.

  6. Using your Accounts-archive sheet as a reference, reselect your accounts using the dropdown menu in column A on the new Accounts sheet and apply class overrides as needed and assign accounts to groups if desired.

Step 7: (optional) Set up manual accounts in Tiller Money Feeds

The new Accounts sheet doesn't give the option to save balances for manually tracked accounts like the original version did. Manual accounts are entered and updated using the Tiller Money Feeds add-on. If you were manually tracking accounts in the right side area of the Accounts sheet follow these steps:

  1. In your new sheet, open the Balance History sheet (from View menu > Hidden sheets > show Balance History if you don't see the tab)

  2. Filter the Balance History sheet to only show accounts with an index of 9999. You may need to unhide the index column.

  3. Sort the Balance History sheet by Account or Account name column.

  4. Launch the Tiller Money Feeds add-on (from the Add-ons menu at the top of your Google Sheet)

  5. Click "Manual Accounts"

  6. Enter the information for a manual account as it appears in the Balance History sheet. You only need to save one entry per manual account.

  7. Copy the Account ID generated by the Tiller Money Feeds add-on that starts with "manual:" and paste it into all entries for that manual account. ⚠️ Do not use the quick fill square for this step to avoid it enumerating the Account ID.

  8. Repeat steps 6 and 7 for each manual account tracked.

Step 8: Transitioning AutoCat (only necessary if you were using AutoCat)

We've released a new version of AutoCat that is only available in the Tiller Money Feeds add-on. You can read more about the upgrade here.

  1. Open the Tiller Money Feeds add-on (via the Add-ons or Extensions menu at the top of your Google Sheet)

  2. Click "AutoCat" in the sidebar

  3. Click "Migrate" to migrate your ruleset to use the new format.

  4. Learn more about how to use AutoCat.

Notes about Index vs Account ID

We deprecated the Index column fill for Google Sheets when we released the Tiller Money Feeds add-on.

If your customized dashboards, reports, or visualizations were using the Index column in the Balance History to unique identify accounts you will need to modify your visualizations/dashboards to use the Account ID as a unique identifier instead. You should only do this after you have completed all other steps for this transition option.


Did this answer your question?